Service disruption for Square users

Incident Report for Payable Apps

Resolved

This incident has been resolved.
Posted Feb 26, 2025 - 18:56 EST

Identified

Square is currently experiencing a disruption that is impacting payment acceptance among other issues. Payable users that use Square as a payment provider may be impacted by this disruption with checkouts taking longer than usual to process a payment, or potential failed payments. Square's Engineering team is currently working to resolve this.
Posted Feb 26, 2025 - 16:16 EST
This incident affected: Payment Providers (Square).